What to do when launching Velodoc XP returns Http Error 404

Coordinator
Oct 30, 2008 at 12:36 AM
Edited Nov 8, 2008 at 2:49 PM
After installing Velodoc XP Edition and launching the desktop shortcut, the browser may return Http Error 404 - Page Not Found under certain circumstances. In particular this occurs if .NET framework 2.0 has been installed prior to installing IIS on Windows Server 2003.

In this case:
  1. the ASP.NET Web Service Extension is not authorized or may not even exist;
  2. the script map linking .aspx files to aspnet_isapi.dll is not recorded.
To configure IIS to execute ASP.NET applications you may have to run  
%WINDIR%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i -enable

Even after registering ASP.NET 2.0 with IIS as described above, the application may still not execute.
In this case, delete and recreate the VelodocXP web application (with read and script authorizations) or reinstall.
Feb 2, 2009 at 9:06 PM
After installing on an x64 computer, .dat files are not processed and Http 404 errors are returned.
To make it work, open IIS manager, display VeloDoc virtual directory properties.
Open the application configuration page (Configuration... button), find .dat files in the list and click Change.
Add "64" at the end of the "Framework" directory name, eg : C:\WINDOWS\Microsoft.NET\Framework64\
Note that all other file types refer to this folder.
The reason is .NET Framework 32 bits is not allowed as a web extension on a 64 bit system.
Maybe the installer should be improved.
Anyway, this program is really a great job.